Category: Linux

Dec 18

Unable to append tape with MTWEOFI enabled

HP Data Protector

I’ve observed the following issue on Media Agents on Linux with MTWEOFI support turned on in omnirc (to optimize performance) when running recent versions of Data Protector such as A.09.09_116. While the first write operation to a blank or expired media will succeed an append operation to a tape by the Linux Media Agent will generate …

Continue reading

Oct 02

Resolve Media Changer issues

HP Data Protector

Recently I had to troubleshoot an issue where loading and unloading tape drives in a tape library was causing trouble. Parallel operations executed on the same library changer device caused a subset of the operations to fail leading to aborted sessions. A Linux Media Agent controlling the library changer reported the following error. [Normal] From: …

Continue reading

Aug 19

Tape drive performance with MTWEOFI on Linux

Physical tape drives are a precious resource in today’s fast growing data centers. If you’re running backups or copies to physical tape drives performance is key. I did some research on this topic based on a customer request. They reported that backups on Windows clients where much faster compared to Linux clients when writing directly …

Continue reading

May 28

Clustered Cell Manager requires omnirc parameter

HP Data Protector

I just stumbled across an issue introduced with Data Protector A.08.00 and the new PostgreSQL database on clustered Cell Managers running on Linux and HP-UX. It’s related to restoration of IDB configuration files back to the shared disk. As you might know, parts of the Data Protector installation are stored on shared disk for a clustered configuration. The directory structure remains the same, but symlinks …

Continue reading

May 09

Re-initialize Data Protector IDB (PostgreSQL)

HP Data Protector

This post will show you how to re-initialize the Internal Database of Data Protector 8 or later to start from scratch without the need for re-installation. This was quite simple on previous versions and needs to be adjusted for the new PostgreSQL database and JBoss application server. These instructions will work on Linux and HP-UX. If I find a proper …

Continue reading

Sep 04

Data Protector Quick Fixes

HP Data Protector

There are situations in which you receive test modules or quick fixes from HP support to resolve a specific issue in your environment. Even if they provide instructions on how to apply them, I found the following general procedure working quite well for Linux clients and cell managers. Upload the fix to the client system …

Continue reading

Aug 14

Data Protector Push installation for Debian clients

HP Data Protector

Integrating Debian or Debian-based Linux clients (e.g. Ubuntu) into a Data Protector cell could be a pain, if you have more than a bunch of them. Patch rollout and release upgrades will even take more time if you poke around with alien to convert the Data Protector rpm into deb format. There are some simple requirements …

Continue reading

Jul 22

Patch Data Protector standalone client

HP Data Protector

There are cases in with you need to apply GA patches to a UNIX client and you don’t have an Data Protector UNIX IS (Installation Server) available. This is worse, because the patches are designed to update an installation server only. The following procedure will help you out. Instead of applying the patches to an …

Continue reading

Jul 21

Data Protector requirements for Linux CM / revised

HP Data Protector

Here are some required, but not well documented requirements for Data Protector Cell Manager (Cell Server) installation on the Linux platform. Update: This information has been revised for SLES11. These steps are not intended to replace the Installation and Licensing documentation shipped with the media kit. Rather they should help you to bring things up …

Continue reading

Oct 31

Gentoo Linux: Hyper-V R2 Enlightenment

If you ever worked with Hyper-V on Windows 2008 R2 you might know the Linux support is still an issue compared to other hypervisors like VMware. In the meantime Microsoft official supports SLES and RHEL as Hyper-V R2 guests. To have them running smoothly, you should install the Linux Integration Services Version 3.1 for Hyper-V …

Continue reading